WordPress Vulnerability Roundup: April 2020, Part 2

Written by

on

Last Updated On

New WordPress plugin and theme vulnerabilities were disclosed during the second half of April, so we want to keep you aware. In this post, we cover recent WordPress plugin, theme and core vulnerabilities and what to do if you are running one of the vulnerable plugins or themes on your website.

The WordPress Vulnerability Roundup is divided into four different categories:

  1. WordPress core
  2. WordPress plugins
  3. WordPress themes

Each vulnerability will have a threat rating of Low, Medium, High, or Critical.

WordPress Core Vulnerabilities

WordPress versions below 5.4.1 have multiple vulnerabilities.

  1. Password Reset Tokens Were Not Properly Invalidated
  2. Unauthenticated Users Could View Private Posts
  3. Cross-Site Scripting Vulnerabilty in Customizer
  4. Cross-Site Scripting Vulnerabilty in Search Block
  5. Cross-Site Scripting Vulnerabilty in wp-object-cache
  6. Cross-Site Scripting Vulnerabilty in File Uploads
  7. Stored Cross-Site Scripting Vulnerabilty in Customizer

The vulnerabilities are patched, and you should update to version 5.4.1.

WordPress Plugin Vulnerabilities

Several new WordPress plugin vulnerabilities have been discovered this month so far. Make sure to follow the suggested action below to update the plugin or completely uninstall it.

1. Accordion Medium

The vulnerability is patched, and you should update to version 2.2.9

2. Widget Settings Importer/Exporter High

Remove the plugin. It is closed on WordPress.org pending review.

3. Media Library Assistant Critical

The vulnerability is patched, and you should update to version 2.82.

4. GTranslate Medium

GTranslate versions below 2.8.52 have a Reflected Cross Site Scripting vulnerability.

The vulnerability is patched, and you should update to version 2.8.52

5. Catch Breadcrumb Medium

Remove the plugin. It is closed on WordPress.org pending review.

6. WP GDPR Core High

Remove the plugin. It is closed on WordPress.org pending review.

7. MapPress Maps for WordPress Critical

The vulnerability is patched, and you should update to version 2.2.9.

8. YOP Poll Low

The vulnerability is patched, and you should update to version 6.1.5.

9. Duplicate Page and Post High

The vulnerability is patched, and you should update to version 2.5.7.

10. WP Post Page Clone High

Remove the plugin. It is closed on WordPress.org pending review.

11. Simple File List Critical

Simple File List versions below 4.2.3 have a Remote Code Execution Vulnerability.

The vulnerability is patched, and you should update to version 4.2.3.

12. Real-Time Find and Replace High

The vulnerability is patched, and you should update to version 4.0.2.

WordPress Themes

1. OneTone High

All versions of OneTone have an Unauthenticated Stored Cross-Site Scripting vulnerability.

Remove the theme. It is closed on WordPress.org pending review.

How to Be Proactive About WordPress Theme & Plugin Vulnerabilities

Running outdated software is the number one reason WordPress sites are hacked. It is crucial to the security of your WordPress site that you have an update routine. You should be logging into your sites at least once a week to perform updates.

Automatic Updates Can Help

Automatic updates are a great choice for WordPress websites that don’t change very often. Lack of attention often leaves these sites neglected and vulnerable to attacks. Even with recommended security settings, running vulnerable software on your site can give an attacker an entry point into your site.

Using the iThemes Security Pro plugin’s Version Management feature, you can enable automatic WordPress updates to ensure you are getting the latest security patches. These settings help protect your site with options to automatically update to new versions or to increase user security when the site’s software is outdated.

Version Management Update Options
  • WordPress Updates –Automatically install the latest WordPress release.
  • Plugin Automatic Updates – Automatically install the latest plugin updates. This should be enabled unless you actively maintain this site on a daily basis and install the updates manually shortly after they are released.
  • Theme Automatic Updates – Automatically install the latest theme updates. This should be enabled unless your theme has file customizations.
  • Granular Control over Plugin and Theme updates – You may have plugins/themes that you’d like to either manually update, or delay the update until the release has had time to prove stable. You can choose Custom for the opportunity to assign each plugin or theme to either update immediately (Enable), not update automatically at all (Disable) or update with a delay of a specified amount of days (Delay).
Strengthening and Alerting to Critical Issues
  • Strengthen Site When Running Outdated Software – Automatically add extra protections to the site when an available update has not been installed for a month. The iThemes Security plugin will automatically enable stricter security when an update has not been installed for a month. First, it will force all users that do not have two-factor enabled to provide a login code sent to their email address before logging back in. Second, it will disable the WP File Editor (to block people from editing plugin or theme code), XML-RPC pingbacks, and block multiple authentication attempts per XML-RPC request (both of which will make XML-RPC stronger against attacks without having to turn it off completely).
  • Scan for Other Old WordPress Sites – This will checks for other outdated WordPress installs on your hosting account. A single outdated WordPress site with a vulnerability could allow attackers to compromise all the other sites on the same hosting account.
  • Send Email Notifications – For issues that require intervention, an email is sent to admin-level users.

Managing Multiple WP Sites? Update Plugins, Themes & Core At Once from the iThemes Sync Dashboard

iThemes Sync is our central dashboard to help you manage multiple WordPress sites. From the Sync dashboard, you can view available updates for all your sites and then update plugins, themes, and WordPress core with one click. You can also get daily email notifications when a new version update is available.

Try Sync FREE for 30 daysLearn more

A WordPress Security Plugin Can Help Secure Your Website

iThemes Security Pro, our WordPress security plugin, offers 30+ ways to secure and protect your website from common WordPress security vulnerabilities. With WordPress, two-factor authentication, brute force protection, strong password enforcement, and more, you can add an extra layer of security to your website.

Learn more about WordPress security with 10 key tips. Download the ebook now: A Guide to WordPress Security



Source link

Leave a Reply

Your email address will not be published. Required fields are marked *